3D Viewer doesn't work with Java8

mac-os
java-8
java3d
3d-viewer
Tags: #<Tag:0x00007fd5430d5988> #<Tag:0x00007fd5430d5488> #<Tag:0x00007fd5430d4ee8> #<Tag:0x00007fd5430d4ce0>

#1

Hello

I run Fiji on Mac OS High Sierra Version 10.13.1 with Java8. Everytime I want to use the 3D-Viewer, a plain black window opens and it seems to stop loading the picture at 1%.
Can anyone help?

Thanks


#2

Hi @Oshawott,

Welcome to the forum.

Issues with the 3d viewer and java 8 are unfortunately known and common:

It’s worth checking out those threads, but @ctrueden’s recommendation above (from May) is:

For immediate results: stick with Java 6 + Java 3D 1.5

:man_shrugging:
John


#3

Thanks @bogovicj for summarizing the situation.

Unfortunately, there is one additional point: for macOS Sierra and High Sierra, there are often fatal problems with Java 6 + Java 3D 1.5 now. It seems that the OS upgrades from earlier versions remove critical pieces of the Java framework, which do not get installed into the same places when you download and install Java 6 manually on Sierra or High Sierra systems. See this thread for details.

So if your goal is to “stick with Java 6 + Java 3D 1.5” then I would also suggest not upgrading to Sierra or High Sierra. The situation is problematic enough now that I may need to pour in more development resources (myself or one of my students) early next year to make Java 8 + Java 3D 1.6 work better on the latest macOS versions.

@Oshawott Have you tried using SciView? It is still alpha quality, but built on newer technology which may work better for you.


#4

Thanks for your help! I want to try SciView, but how do i install this plugin? I´ve tried to copy paste the “SciView-master” folder in the Fiji “plugin” folder, but unfortunately Fiji does not recognize SciView.


#5

I asked @kephale about the best way to install it, but actually, there is no update site yet. We plan to remedy that at the upcoming hackathon in early December. We’ll announce as soon as an update site is available for it.