Bio-Formats exception on.zvi read

bio-formats
Tags: #<Tag:0x00007fb87b852e98>

#1

Can anyone explain the exception and or suggest a workaround? Thanks. I can’t figure out how ta supply the plugin version, but I did just run update.

(Fiji Is Just) ImageJ 2.0.0-rc-43/1.51k; Java 1.8.0_121 [64-bit]; Windows 10 10.0; 53MB of 24425MB (<1%)
 
java.lang.NoSuchFieldError: MICROMETER
	at loci.formats.in.NiftiReader.<init>(NiftiReader.java:78)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
	at java.lang.Class.newInstance(Class.java:442)
	at loci.formats.ImageReader.<init>(ImageReader.java:129)
	at loci.formats.in.FilePatternReader.<init>(FilePatternReader.java:77)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
	at java.lang.Class.newInstance(Class.java:442)
	at loci.formats.ImageReader.<init>(ImageReader.java:129)
	at loci.plugins.util.LociPrefs.makeImageReader(LociPrefs.java:94)
	at loci.plugins.in.ImportProcess.createBaseReader(ImportProcess.java:617)
	at loci.plugins.in.ImportProcess.initializeReader(ImportProcess.java:484)
	at loci.plugins.in.ImportProcess.execute(ImportProcess.java:137)
	at loci.plugins.in.Importer.showDialogs(Importer.java:140)
	at loci.plugins.in.Importer.run(Importer.java:76)
	at loci.plugins.LociImporter.run(LociImporter.java:78)
	at ij.IJ.runUserPlugIn(IJ.java:217)
	at ij.IJ.runPlugIn(IJ.java:181)
	at ij.Executer.runCommand(Executer.java:137)
	at ij.Executer.run(Executer.java:66)
	at java.lang.Thread.run(Thread.java:745)

Error when opening movies
#2

Dear @RobBaer,

how did you obtain that particular ZVI file that you are trying to open? Is it really a ZVI file or might it be a different file format that has misleadingly been saved as ZVI?

In any case, this looks like a bug in Bio-Formats. Hence you should also report it to the Bio-Formats team.

Best,
Stefan


#3

Yes, it is/was a genuine .zvi. It opened just fine with Axiovision.so it was not corrupt. Everything “read” up-to-date by the FIji update checker. I ultimately deleted Fiji and decided to start over with a fresh install. However, I got distracted and don’t know the results yet.

In the meantime, the very same file opens fine with Fiji on my work computer. One of my working hypotheses is that there is something about having had the 3DViewer beta and or java 3D installed at home that may be caucusing issues. This is just a wild, unsubstantiated guess as it is the most “out of stock” thing that was true of my home Fiji install.

I’m not at the “reproducible enough” stage, to file a BioImage Format bug report yet.


#4

I actually just stumbled across the following thread:

Could you please check if you have the Java-8 update site enabled on your home machine? The ImageJ2 version seems to be rc43 which points to not having the Java8 update site enabled. Following that site might already solve your issue…


#5

Thanks. Fiji is reinstalled. The Java update site is checked, and best of all, my .zvi files are opening again on this machine. Appreciate the help.