Bioformats export as OME.TIFF scale bug

export
ome-tiff
bio-formats
Tags: #<Tag:0x00007fd547be3d08> #<Tag:0x00007fd547be3b50> #<Tag:0x00007fd547be3768>

#1

I was resaving an image stack (3 channels, 1 slice, 100 timepoints) to a series of ome.tif files, one for each time point.
I used BioFormats Exporter.

The new images have now lost the calibration and lookup tables that were on the original.

Has anyone had other issues with this?

EDIT: The channels are also now considered as Z slices

Best regards
Oli


TrackMate export (XML) code in Matlab
#2

Hi @oburri,

how did you open the files after exporting with the Bio-Formats Exporter? By any chance via drag & drop or File > Open? If so, I could reproduce the issue you are describing.

Could you instead try to import the files with the Bio-Formats Importer?

The symptoms you are describing sound familiar, namely that ImageJ interprets the OME-TIFF as a “normal” TIFF file and cannot obtain the required meta information from the TIFF header (since Bio-Formats doesn’t write those).

Best,
Stefan


#3

Dear Stefan,
Indeed importing from BioFormats fixes this issue, though I have to specify the timepoint I want to import, otherwise it tries importing the whole hyperstack.

In a related issue, if I try to export as tif, not ome.tif, opening the image by drag&drop causes some major issues with the data


Importing one of these tifs via BioFormats importer works though. But what is different about these tiffs that make the vanilla ImageJ Opener not manage to get the pixel data correctly?


#4

Sometimes it is hard to determine if something is a bug or a feature. In that case, I guess it is intended behavior to keep a time-series that originates from a single stack grouped together. It still feels a little odd, because you can’t just delete files from the series since it seems to invalidate the whole thing.

Do you have Edit > Options > ImageJ2 > Use SCIFIO when opening files enabled? In any case, could you try to save the image via File > Export > Image and import it again via File > Import > Image. Can you observe the same issue this way?


#5

I have a similar problem where I am exporting .lif files to Fiji, but when I export the file as .ome.tiff, the data appears to be stretched in the z-axis and the reconstruction does not make sense. Do you have any suggestions on how to fix this issue? I want to ideally bring .lif files from the Confocal Microscope as .ome.tif to Amira.

Thanks,
Azman


#6

You already asked this here:

I suggest to continue the discussion on that new topic, as this topic here is marked as solved.