Blank window using Morphological segmentation - MorpholibJ

morpholibj
segmentation
fiji
Tags: #<Tag:0x00007fd541ddb030> #<Tag:0x00007fd541ddaef0> #<Tag:0x00007fd541ddadb0>

#1

Hello,

I am trying to use the morphological segmentation from the plugin, MorpholibJ and everytime I try to run it the only thing that I obtain is a blank window called “Morphological segmentation (3200%)”.

I have already used this plugin on another computer at work (that I can not access right now) and had no problem with it.

The images that I am using are TIFF images in 16bit. I had no problem with the exact same images on my computer at work.

I downloaded the last version of Fiji with the last version of MorpholibJ and tried to update everything and restarted the program multiple times on my own computer at home (it is running windows 10).
I also tried to run it on another computer at home that is running windows 8 and the same problem appeared.

Do you have any idea of how I could solve my problem ?

Thank you !


#2

Hello @Ambre_Miassod and welcome to the ImageJ forum!

Thanks for reporting!I have had occasionally a similar problem which I believe to be related to the size of the image and the resolution of the screen. Can you please tell me both?


#3

Thank you !

For the size it goes from 55ko to 180ko depending on the image and my screen resolution is 1366x768.


#4

Do you mean 55K x 55K pixels and 180K x 180K pixels? And do you get the error with all of those sizes?


#5

Ho sorry I was thinking about the size of the file not the size of the actual image…

So for the size in pixel it is around 250 x 250 px for each image.
I have not tested all of them (I’ve got 30) but I had the error each time.


#6

OK, I can reproduce the error on my machine (under OS). I will work on it and be back to you as soon as possible with a solution.

Thanks again for reporting!


#7

Dear @Ambre_Miassod,

I have fixed the issue with this commit. It will be included in the new release, coming out soon!

ignacio


#8

Thank you so much @iarganda :slight_smile:


#9

Sorry for the delay, @Ambre_Miassod, the issue has been fixed with MorphoLibJ’s release v1.3.3.