Converting .STL file into stack of images

imageconverter
stackconverter
3d-viewer
fiji
Tags: #<Tag:0x00007fb87cfec450> #<Tag:0x00007fb87cfec2c0> #<Tag:0x00007fb87cfec180> #<Tag:0x00007fb87cfec040>

#61

Sorry about this. The reason I’m delaying a bit is that I need 1 package upstream to be officially released before the fix is really permanent. I am still watching this like a hawk, and will fix it as soon as ThreeDViewer can be built using release dependencies only.


#62

@skalarproduktraum: ^ Your hard work has impact!


#63

Hello everyone! I’m sorry that the scenery release, which is now holding up ThreeDViewer, is taking a little longer. The reason is that there have been quite a few things to figure out for me, which took longer than expected. Among them are

  • how to publish artifacts to a Maven repository, for the same release, from different CI build workers/operating systems
  • how to get a spot on Maven central, and put the resulting artifacts there in a stable way.
    This is now (mostly) done, I’m ironing out one more bug, then there will be a release, hopefully beginning of the next week.

I’ll also do a little write-up on the distributed native CI builds, so others might also enjoy this :smiley:

cheers and sorry again for the delay!


#64

Well worth the wait!


#65

No need whatsoever to apologize! I meant my comment encouragingly, like: your work is used and appreciated! People anxiously await, because it has impact!

Thank you very much for sorting that out.

:+1:

Agreed.


#66

Dear forum,
I am very excited to get to know this method. It has been a long time since this question was posted, but I was stuck at the very first few steps I think. I installed the Fiji imageJ, and I can import the stl file in the 3D viewer. But I cannot find the voxelize mesh button after I have done the update from the update sites. I attached the process from the very beginning as the followings:

(1) Download Fiji imageJ from https://fiji.sc/#download;
(2) check the funimage update in the Fiji and click the apply changes;


(3) And here is my Fiji.app content

and plugin directory (I feel different from other people…);

(4) And here is in the 3D viewer of my imagej…

Could you please help me to find out which step I need to change or other things I need to do?
@kephale

Sorry I didnt read the whole thing…I tried ThreeDviewer, but does not work, will wait until it works, thank you!


#67

Report from Windows 10 user:. Bug tracking seems under construction so reporting here. FWIW, I updated my java from 8_111 to 8_121 but it didn’t help

http://sites.imagej.net/ThreeDViewer

The associated .jar list:

Clicking ThreeDViewer | Launch produces the following exceptions:

(Fiji Is Just) ImageJ 2.0.0-rc-43/1.51j; Java 1.8.0_121 [64-bit]; Windows 10 10.0; 109MB of 24425MB (<1%)
 
java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.NoClassDefFoundError: graphics/scenery/SceneryDefaultApplication
	at net.imagej.legacy.LegacyService.runLegacyCompatibleCommand(LegacyService.java:274)
	at net.imagej.legacy.DefaultLegacyHooks.interceptRunPlugIn(DefaultLegacyHooks.java:161)
	at ij.IJ.runPlugIn(IJ.java)
	at ij.Executer.runCommand(Executer.java:137)
	at ij.Executer.run(Executer.java:66)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.util.concurrent.ExecutionException: java.lang.NoClassDefFoundError: graphics/scenery/SceneryDefaultApplication
	at java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.util.concurrent.FutureTask.get(FutureTask.java:192)
	at net.imagej.legacy.LegacyService.runLegacyCompatibleCommand(LegacyService.java:270)
	... 5 more
Caused by: java.lang.NoClassDefFoundError: graphics/scenery/SceneryDefaultApplication
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:763)
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
	at java.net.URLClassLoader.defineClass(URLClassLoader.java:467)
	at java.net.URLClassLoader.access$100(URLClassLoader.java:73)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:368)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:362)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:361)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	at sc.fiji.threed.ThreeDViewerLauncher.run(ThreeDViewerLauncher.java:31)
	at org.scijava.command.CommandModule.run(CommandModule.java:201)
	at org.scijava.module.ModuleRunner.run(ModuleRunner.java:167)
	at org.scijava.module.ModuleRunner.call(ModuleRunner.java:126)
	at org.scijava.module.ModuleRunner.call(ModuleRunner.java:65)
	at org.scijava.thread.DefaultThreadService$2.call(DefaultThreadService.java:191)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	... 1 more
Caused by: java.lang.ClassNotFoundException: graphics.scenery.SceneryDefaultApplication
	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 22 more

#68

As far as I can see, that’s essentially the same error as in the :point_up: earlier post above by @darylhyun.

And as stated above, we should be patient until @skalarproduktraum and others have solved the issues with scenery :slight_smile:


#69

I’m acknowledging that I see these updates. Apologies for the delay, progress is being made.


#70

I can still not launch the threedviewer. Does the bugs fixed? Im looking forward to this function.


#71

No, not yet.

@kephale I filed a PR to update the ThreeDViewer code to use the stable release of scenery et. al: kephale/ThreeDViewer#40.

@skalarproduktraum @kephale I would like to start managing the versions of ClearVolume etc. components in the pom-scijava Bill of Materials. Could you post a list of GAVs you want to be included? Our goal should be for ThreeDViewer to declare no explicit versions of any components in its POM.


#72

Hi @ctrueden!

Sorry for the late reply, I managed to miss the notification. Could you clarify what the benefit of putting the GAVs into pom-scijava is? Is the idea to not have nasty issues with different plugins using different versions?

Thanks!


#73

Yes. The idea is to become part of the global SciJava Bill of Materials—i.e., officially be part of the SciJava component collection. :smile: Then downstream components can depend on your stuff without worrying about version numbers.


#74

Hello,

@kephale First many thanks for providing such an excellent feature. I have the same Java problem as other users when launching ThreeDViewer. Are you still working on it? Look forward to your updates.

BR,
Chuanyue


#75

Yes, we’re putting a ton of effort in at the moment. The official rebranding will be SciView, and although we haven’t bothered with the public-facing documentation on the Wiki yet, that information will be available here: http://sc.iview.sc. We will be rolling out early releases by early August.

Cheers!
Kyle


#76

Thank you very much and look forward to the releases.

Cheers!
Chuanyue