Digest notifications


#1

Hi,
I have not visited for a few days and I have set the preferences to notify me “weekly”. but I am being sent “digests” twice a day, for the last 2 or 3 days.
Any ideas if this is a bug or is it me not understanding what the “weekly” setting means.
Cheers!


#2

Same here. Too much mail.


#3

Same here, received 10 mails in the last three days. My setting is set to once every three days.

Regards,
Bonehead


#4

Looks like something buggy is going on with Discourse.

E-mail logs say that digests are being sent out every 4-6 hours… to everyone…

The default is supposed to be “every 3 days”, and the digest times are supposed to be “after not visiting the site for x days”

Anyway I just tried clearing and resetting things. If anyone gets a digest e-mail earlier than the specified wait time after their last forum visit, please let me know and I will disable Digests and open an issue on meta.discourse


#5

Thanks hinerm, I have not received any emails since yesterday. Before seemed it seemed to work fine. This happened in the last week or so.


#6

There were definitely upgrades last week, including a rebuild of the Discourse Docker container. So it seems very likely that the upgrade introduced this bug.

Anyway I will also monitor what e-mails Discourse sends out for a few hours to see if it’s still digest spamming.

Thanks for the feedback; apologies for the inconvenience.


#7

Looks like the digest mails are still going out.

Bug filed.

Sorry again to everyone who’s being spammed. I’m going to disable digest e-mails for now, but will continue to monitor.


#8

Thanks for the quick follow-up, @hinerm. It seems the Discourse team has now fixed this bug! I am out of the office today, but @hinerm or I will upgrade the system again (and reenable the digest feature) as soon as we get a chance. Hopefully tomorrow, unless the impending Madison snowstorm trashes us too badly. :wink:


#9

Ah I thought I posted a message yesterday but I guess it didn’t go through. I upgraded and re-enabled digests before leaving yesterday. :slightly_smiling:

But… looking at the e-mail logs, discourse is still sending e-mails every 6 hours. There was another upgrade this morning which I just ran, so we’ll see…


#10

Odd notifications again from this forum.
I received one today with links to imagej.trydiscourse.com saying that I have not visited from Dec 11 and also 1 (!) new topic since that time. Wrong in both counts.
The link does not point to this site address, is that correct or is some kind of phishing going on?
Thanks.


#11

I got the same email linking to the trydiscourse site… where I am prompted to log in.

Feels phishy.

From imagej@discoursemail.com.


#12

Apologies—it was not phishing, but a leak from the test environment leading up to the new image.sc forum. See:

A user somehow found the temporary test environment at imagej.trydiscourse.com and created a new topic there, which then triggered an email to the entire userbase. :disappointed: We subsequently disabled all outgoing mail.