File not found: META-INF/json/org.scijava.plugin.Plugin


#1

Hi All,

I am using maven > install on this pom: https://github.com/tischi/fiji-plugin-imageRegistration/blob/master/pom.xml
…and I am getting below error.

@haesleinhuepf was so kind to test it and he does not get this error when he clones the repo onto his computer. My feeling is that the problem is that I changed class and package names during development and that there are somewhere traces of the old stuff confusing the compilation…

INFO] --- maven-compiler-plugin:3.6.0:compile (default-compile) @ fiji-plugin-imageRegistration ---
[INFO] Compiling 40 source files to /Users/tischer/Documents/fiji-plugin-imageRegistration/target/classes
[INFO] -------------------------------------------------------------
[ERROR] COMPILATION ERROR : 
[INFO] -------------------------------------------------------------
[ERROR] java.nio.file.NoSuchFileException: /Users/tischer/Documents/fiji-plugin-imageRegistration/target/classes/META-INF/json/org.scijava.plugin.Plugin
 	at java.base/sun.nio.fs.UnixException.translateToIOException(UnixException.java:92)
 	at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:111)

#2

Hi @Christian_Tischer,

if you rename classes marked as @ Plugin, you may need to execute

mvn clean

Does this help?

Cheers,
Robert


#3

Hi @haesleinhuepf,
I tried maven > clean already but it did not help.
Best, Tischi


#4

Turns out I did not have to change anything inside by development environment, but reinstall the Fiji that was the target of the maven install. Now it works.