Getting accurate results

fiji
Tags: #<Tag:0x00007fa3069f5460>

#1

Hi,

Please I have a problem to calculate accurate area for two phases.
First I have done a segmentation using Trainable Weka Segmentation and I got probability map for each see the following image probability image

I have make threshold for each phase and then create mask for each phase as well
as below
grain-threshold (grain threshold)
grain (grain mask)

threshold (liquid threshold)
mask (liquid mask)

the problem is when I try to calculate the area I got the same results for each type
results
and it should be different.
I think I can use analyze particles because these image are not related to particles.

Please could you advice me how can I get an accurate area calculation for each type?

Reagrds


Macro Language Help
#2

Hi,

Please activate “limit to threshold” in Analyze > Set Measurements.

That should fix the issue.

Best


#3

Hi oburri,

Thanks for your promote reply.
I have activated “limit to threshold” as you suggested but I got the same results i.e the same area for the different phases which Im sure it should be quite different according to the visualize images form the microscope.

I would be much appreciated if you have any further suggestion that could help to tackle this issue. Im a new user with imageJ and I dont have much experience with such software.

Best regards
Arije


#4

Downloading your image, measuring with only Area and ‘min &max grey value’ set, then in ‘Set Measurements’ having checked Area and Limit to threshold, then having checked in Image>Adjust>Threshold… Default Red ‘Dark background’ Auto, and measuring again, in the Results window I get these results:

2	185690	0	255 
3	92846	129	255

So what are you doing prior to performing your measurement?


#5

Hi eljonco,

Thanks for your promote reply.
I activated limit to threshold in setting but I think I have to do this before making threshold, since when I checked-in after that I got nearly the same results to what you have already got 92228.

Many thanks for your help, really much appreciated.

Regards
Arije


#6

Actually, you need to have the ‘limit to threshold’ setting ticked before you do the Measure… command.