I can't save ROI sets due to a mysterious read-only file system error


#1

I have zero coding experience and I’m fairly new to Fiji. Right now I’m trying to do some basic structural MRI analysis, and for some reason I can’t save ROI sets. I’m trying to save them to the same remote disc that all of the 2dseq files live on and Fiji just isn’t having it.

Every time I try to save, an error pops up that looks something like “java.io.FileNotFoundExcepection: /Volumes/easystore/ROISet.zip (Read-only file system)”. This is confusing and frustrating to me because this process was working just a couple of weeks ago. I really have no idea what could have gone wrong.

Can anybody help with this?


#2

@LostRAnumber4738
The typical /Volumes/ seems to indicate a Mac OS file system. Some questions:
‘this process was working’: on exactly the same external drive, using the same connector?
Did you upgrade your OS recently?
Did you inspect Sharing & Permissions on the easystore disk (File>Get Info)
Is the easystore disk a writable system (e.g. NTFS is readable but not writable)
Has the easystore been attached to a different computer in the meantime?


#3

Yes, it was working on the exact same external drive with the same connector.

I also did upgrade my OS about a week ago.

I just looked at sharing and permissions and it now says “you can only read.”

The format says NTFS.

Nope.


#4

By default, Mac OSX doesn’t support writing on NTFS volumes. Maybe you had enabled writing to NTFS in the past, and it got reset somehow during your OS upgrade?


#5

That would make sense. I don’t know how I would have done that, but I’m not particularly techie so my normal approach to installing things like Fiji is essentially the software equivalent of button mashing.

I’m going to try installing an NTFS driver to see if that helps. Thanks!


#6

The obvious other option would be to re-format and partition the drive using Disk Utility (and losing all your data currently on the disk). Don’t forget to change the partition map to the proper format too.