ImageJ2 on OpenVMS

openvms
Tags: #<Tag:0x00007fb882fba5f8>

#1

I’m trying to get Fiji-ImageJ running on my OpenVMS systems. Ofcourse there is no launcher present so I tried to run the .jar files directly.

I got some succes with
java -Xmx256m -Djava.awt.headless=false -d64 -jar [.jar]ij-1.51l-SNAPSHOT.jar

It looks more or less the same as on my linux system, but I’m bothered by the 1.5 : is this realy ImageJ2 or is this a campatibility mode?
What is the proper .jar file to run? I also tried ImageJ-2.0.0-rc59.jar but that one gave an error

                Jouk

#2

Welcome to the forum, @joukj!

Sorry for my ignorance, but does OpenVMS include a POSIX-compliant shell? If so, I suggest using the ImageJ.sh launch script. And in that case, the instructions for the Raspberry Pi are probably pretty close to on target for OpenVMS as well. If they work for you, let’s create an OpenVMS page in Category:Platforms and add it to that section of the wiki.

Yes, the invocation you already tried simply runs ImageJ 1.x, without the ImageJ2 parts.

If you need a very simple one-liner, you could try this:

java -cp 'jars/*:jars/bio-formats/*:plugins/*' net.imagej.Main

#3

Yes, there is a port of the bash. I’ll try that one first…

      to be continued

               Jouk

#4

Hmm… not very sucessfully; I’m still missing things:

gigue-jj) bash -c ImageJ.sh
ls: cannot access /$disk16/JOUKJ/public/imagej/Fiji.app-2017040/jars/ij-launcher*.jar: no such file or directory
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option PermSize=128m; support was removed in 8.0
Java HotSpot(TM) 64-Bit Server VM warning: Using incremental CMS is
deprecated and will likely be removed in a future release
Error: Could not find or load main class net.imagej.updater.ClassLauncher

Jouk

I did not find the ij-launcher*.jar: on my machine…


#5

When I use the suggested simple liner I get Errors:

12:23:36,668 |-INFO in ch.qos.logback.classic.LoggerContext[default] - Could NOT find resource [logback.groovy]
12:23:36,670 |-INFO in ch.qos.logback.classic.LoggerContext[default] - Could NOT find resource [logback-test.xml]
12:23:36,672 |-INFO in ch.qos.logback.classic.LoggerContext[default] - Found resource [logback.xml] at [jar:file:/$DISK16/JOUKJ/PUBLIC/IMAGEJ/FIJI.APP-20170407/jars/scijava-config-2.0.1.jar!/logback.xml]
12:23:36,738 |-INFO in ch.qos.logback.core.joran.spi.ConfigurationWatchList@7777e10 - URL [jar:file:/$DISK16/JOUKJ/PUBLIC/IMAGEJ/FIJI.APP-20170407/jars/scijava-config-2.0.1.jar!/logback.xml] is not of type file
12:23:36,740 |-ERROR in ch.qos.logback.classic.joran.JoranConfigurator@6c3023d3 - Could not open URL [jar:file:/$DISK16/JOUKJ/PUBLIC/IMAGEJ/FIJI.APP-20170407/jars/scijava-config-2.0.1.jar!/logback.xml]. java.io.FileNotFoundException: /$DISK16/JOUKJ/PUBLIC/IMAGEJ/FIJI.APP-20170407/jars/scijava-config-2.0.1.jar (i/o error)
	at java.io.FileNotFoundException: /$DISK16/JOUKJ/PUBLIC/IMAGEJ/FIJI.APP-20170407/jars/scijava-config-2.0.1.jar (i/o error)
	at 	at java.util.zip.ZipFile.open(Native Method)
	at 	at java.util.zip.ZipFile.<init>(ZipFile.java:220)
	at 	at java.util.zip.ZipFile.<init>(ZipFile.java:150)
	at 	at java.util.jar.JarFile.<init>(JarFile.java:166)
	at 	at java.util.jar.JarFile.<init>(JarFile.java:103)
	at 	at sun.net.www.protocol.jar.URLJarFile.<init>(URLJarFile.java:93)
	at 	at sun.net.www.protocol.jar.URLJarFile.getJarFile(URLJarFile.java:69)
	at 	at sun.net.www.protocol.jar.JarFileFactory.get(JarFileFactory.java:99)
	at 	at sun.net.www.protocol.jar.JarURLConnection.connect(JarURLConnection.java:122)
	at 	at sun.net.www.protocol.jar.JarURLConnection.getInputStream(JarURLConnection.java:150)
	at 	at ch.qos.logback.core.joran.GenericConfigurator.doConfigure(GenericConfigurator.java:52)
	at 	at ch.qos.logback.classic.util.ContextInitializer.configureByResource(ContextInitializer.java:75)
	at 	at ch.qos.logback.classic.util.ContextInitializer.autoConfig(ContextInitializer.java:150)
	at 	at org.slf4j.impl.StaticLoggerBinder.init(StaticLoggerBinder.java:84)
	at 	at org.slf4j.impl.StaticLoggerBinder.<clinit>(StaticLoggerBinder.java:55)
	at 	at org.slf4j.LoggerFactory.bind(LoggerFactory.java:150)
	at 	at org.slf4j.LoggerFactory.performInitialization(LoggerFactory.java:124)
	at 	at org.slf4j.LoggerFactory.getILoggerFactory(LoggerFactory.java:412)
	at 	at org.slf4j.LoggerFactory.getLogger(LoggerFactory.java:357)
	at 	at org.slf4j.LoggerFactory.getLogger(LoggerFactory.java:383)
	at 	at loci.formats.ImageReader.<clinit>(ImageReader.java:66)
	at 	at io.scif.bf.BioFormatsFormat.cacheReaderClasses(BioFormatsFormat.java:487)
	at 	at io.scif.bf.BioFormatsFormat.<init>(BioFormatsFormat.java:135)
	at 	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at 	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
	at 	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at 	at java.lang.reflect.Constructor.newInstance(Constructor.java:422)
	at 	at java.lang.Class.newInstance(Class.java:446)
	at 	at org.scijava.plugin.PluginInfo.createInstance(PluginInfo.java:304)
	at 	at org.scijava.plugin.DefaultPluginService.createInstance(DefaultPluginService.java:236)
	at 	at org.scijava.plugin.DefaultPluginService.createInstances(DefaultPluginService.java:225)
	at 	at org.scijava.plugin.DefaultPluginService.createInstancesOfType(DefaultPluginService.java:216)
	at 	at io.scif.services.DefaultFormatService$2.run(DefaultFormatService.java:451)
	at 	at org.scijava.thread.DefaultThreadService$1.run(DefaultThreadService.java:174)
	at 	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at 	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at 	at java.lang.Thread.run(Thread.java:745)

#6
java.io.FileNotFoundException: /$DISK16/JOUKJ/PUBLIC/IMAGEJ/FIJI.APP-20170407/jars/scijava-config-2.0.1.jar (i/o error)

That suggests that your disk might be going bad. The file jars/scijava-config-2.0.1.jar cannot be read succesfully. What happens if you cp jars/scijava-config-2.0.1.jar ~ or some such? Does it work, or also give an error?

That is a bizarre error: the JAR previously called ij-launcher was renamed to imagej-launcher a long time ago. If you execute ls jars/ij-[a-z]* you should see no files listed. Otherwise, you have a very old version of Fiji!