Installing Fiji on RHEL7 Machine

installation
linux
java-8
Tags: #<Tag:0x00007fd547ba7a38> #<Tag:0x00007fd547ba7768> #<Tag:0x00007fd547ba7588>

#1

Hi,
I downloaded and am trying to launch Fiji using X11 forwarding

Unfortunately I am greeted with the following error upon launch with both the included Java version and the one installed on the machine

[oburri@ptbiopsrv1 fiji]$ ./ImageJ-linux64
OpenJDK 64-Bit Server VM warning: ignoring option PermSize=128m; support was removed in 8.0
OpenJDK 64-Bit Server VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGBUS (0x7) at pc=0x00007fd535012be0, pid=961, tid=0x00007fd5546f2740
#
# JRE version:  (8.0_141-b16) (build )
# Java VM: OpenJDK 64-Bit Server VM (25.141-b16 mixed mode linux-amd64 )
# Problematic frame:
# j  java.lang.Object.<clinit>()V+0
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /opt/fiji/hs_err_pid961.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.java.com/bugreport/crash.jsp
#

Any help is appreciated
Best


#2

This might be the same issue that’s been discussed in these topics:


#3

Hi and thanks for the relpy.

So far what has worked is this

But I had thought that removing the java folder from within the Fiji installation directory ensured that the system’s Java was used…

Well all solved now it seems… Thanks so much @imagejan