MaMuT: Keyboard shortcut failure on Mac

mamut
fiji
Tags: #<Tag:0x00007fd541fddba8> #<Tag:0x00007fd541fdda40>

#1

I am using MaMuT for the annotation. Previously, I was doing that on Ubuntu machine and everything was fine but after switching to macOS I’ve noticed problems with the keyboard shortcuts.

“Arrow up” increases the time step instead of zooming in.
Letter shortcuts, e.g. “M” and “N” are not working at all.

I’ve tried to change the active window switching between main and annotation windows but it didn’t help.

The problem doesn’t show up instantly after starting MaMuT but only after some time of using it.

@tinevez, is this a known issue? Ideas why this might happen?


#2

This is completely new to me, and I could not reproduce on Mac, even after fiddling for < 5 min.
Could you investigate and discover the steps that lead to this inversion?
Do you have a mamut.properties file in your home or in your Fiji folder?


#3

Just checked again – getting the same problem.

I can’t find mamut.properties in either home or Fiji folder.

I’ve attached the video. The last 8 seconds I am repeatedly pressing N and M.


#4

I have been mashing my keyboard overnight and I still cannot reproduce, sorry.
Any chance you could confirm this on another mac?


#5

Just re-installed MaMuT – same problem. :frowning:

I’ll check it on another mac and come back to you on Monday.

What about mamut.properties file? Is this a problem that I don’t have it at all?


#6

Hi @milkyklim,

could you please try clicking in the image and test the keyboard shortcuts m and n again after that? When the time-bar on bottom of the window is selected, apparently not all keys work…

Cheers,
Robert


#7

this is what I was doing before.

If I do these

  1. Click and hold the time slider at the bottom of the image with the mouse
  2. Press N twice

The keyboard shortcuts stop responding.

My guess would be that the key/scroll-Listeners block each other some how.


#8

When you click on the time slider, it gets the keyboard focus.
In that case, all the keypresses you make are not send to the MaMuT keyboard handler, but to the Swing slider keyboard listener.
The later has a binding for the up & arrow key, but when you click back in the viewer window, then the arrow keys should be mapped correctly.

On my mac, it works as expected. So I could not reproduce your bug (thanks for the description though). Let’s call for a 3rd party: @haesleinhuepf what do you say?


#9

I just tried again. I could reproduce @milkyklims issue. Once. After moving time slider and pressing M and N keys randomly for about 30 seconds, the key bindings are lost. Also the A key does not longer add annotations. Clicking in the image does not help either. However, reprdocuing this issue is really hard. I didn’t manage again :frowning:


#10

@tinevez

this is exactly the issue I had and exactly the way I experienced it.

Another (possible related) mac question – if I press M and hold it, should I move forward by one time-step or move forward constantly?