Need help with bonej plugin

local-thickness
bonej
Tags: #<Tag:0x00007fb88680ef08> #<Tag:0x00007fb88680edc8>

#1

Hi, hope you are all doing well.

I have recently installed Fiji on my laptop with bonej plugin. I have difficulty in measuring the thickness of a bone, whenever I click on thickness link, it gets stuck on “EDT transformation 1/3…”. Apart from my supervisor’s computer, it doesn’t work on any other device (I have tried it on mac laptop and windows). Can anyone help me with this please?

Many thanks


#2

Hello Aman,

Depending on the image LocalThickness_ can involve some pretty heavy calculations, and take considerable time. It may be just a case of your supervisor’s computer being more powerful. The LocalThickness_ plugin comes with Fiji by default, so you don’t need to install BoneJ just for that. Have you tried running the stand alone version from the menu path Analyze > Local Thickness? The Local Thickness (masked, calibrated, silent) option in this sub-menu is a tiny bit faster, because it doesn’t display the intermediate steps in the process.

Best Regards,
Richard


#3

Hello Richard,

Thank you for replying. I have an account on my supervisor’s computer as well but bonej plugin didn’t work. I have tried a lot of different computers and i get the same result. I have also tried the stand alone version from the menu path, it didn’t work. I am new to imageJ so I am not sure what the problem is.

This is the image I am working with, I am trying to calculate trabecular thickness. I was told to use the following method: select the area I want to measure, then click clear outside > fill > deselect > invert > convert to 8-bit > bonej > thickness. Would the same method work for stand alone Fiji path as well?
Sorry for so many questions, I have been trying to make it work for ages now.


#4

Note that LocalThickness_ expects a binary image. Thus after Invert call Process > Binary > Make binary. Binarization also makes the image 8-bit, so you can drop that step from your workflow. The plugin ran successfully on my computer after binarization, but took a little while despite my workstation being quite powerful. The same method will work with the stand-alone plugin. I need to add more documentation to the wiki page of LocalThickness_, thank you for pointing out this omission.

Best regards,
Richard

Edit: LocalThickness_ doesn’t actually expect a binary image, it works with any 8-bit grey-scale. Processing a grey-scale image takes a lot longer than binary (10+ minutes), and the results make more sense in the latter case at least to my untrained eye. Also at the moment the plugin accepts an 8-bit colour image, which it shouldn’t. I’m afraid this bug is my handiwork.