NeurphologyJ: absurd outcome from high throughput version

neurons
neuroanatomy
morphology
dendrites
plugin
Tags: #<Tag:0x00007fb87b850850> #<Tag:0x00007fb87b850620> #<Tag:0x00007fb87b8503f0> #<Tag:0x00007fb87b850210> #<Tag:0x00007fb87b850080>

#1

Hi!
I’m trying to use NeurphologyJ for the first time. I started with the high-throughput version: the plugin worked well on my images, but the final numerical output is quite strange; I mean, the measurements have no sense. I understand that the lenghts measured by the software are expressed in pixels, but even with the conversion to micrometers, the numerical outcome is absurd. Using the interactive version, the results seem more reliable and realistic…but I can’t use this version to analyse thousands of images…! Does anyone faced the same problem, and how you overcame it? Thank you


#2

Welcome to the forum, @AriannaM!

I invited the author of NeurphologyJ, Dr. Eric Hwang, to join the discussion on this thread. Hopefully he has some insight into what is going on.


#3

Arianna,

I’m the corresponding author for NeurphologyJ.
Here are a few things you can try:

  1. Downgrade or upgrade your ImageJ to version 1.43, this was the version we used to develop NeurphologyJ.
  2. Look at the output images, do the tracings make sense to you?
    Hope this helps and thanks for using this plugin!

Eric


#4

Hello, thank you very much @hwangeric for the replies and for the help. I tried the 1.43 version of imageJ, but on this version, the plugin does not work.

Using the 1.50 version, I can run the plugin, and the tracings are quite good as you can see the image attached:

.

I cannot understand the final measurements: they are all very similar despite very different tracings, and to me they seem too much high.

Analysing the same image with the interactive version, I have this results (and they seem realiable):

I followed the manual and I don’t know where I’m wrong…
Thank you again for the help! :slight_smile:


#5

Hi Arianna,

Hmm… this is a first for me.
Can you send me a few of your images and I’ll see what I can find out.

Eric


#6

Hi @hwangeric, thank you very much! Can I use this email hwangeric (at) mail.nctu.edu.tw ?
Otherwise, @ctrueden, how can I send some of my images to Eric? I’m not allowed to send private messages yet…
Thank you! :slight_smile:


#7

Can you just post a sample image here? It is better to continue discussing in public whenever possible. That way, others with similar issues will benefit from the thread later.


#8

I’m worried about the type and dimension of the image. Let’s try :slight_smile: @hwangeric


@hwangeric, here some examples:


#9

Arianna,

I tested one image named “390419dcde2057bc744b6fb6f14017fdacf8eec0.tif”.
The results from both interactive and NeurphologyJHT are identical (see images below).
I’m not sure what happened at your end, but perhaps one solution is modify the code of the interactive version so it can run for all images in a folder.
I can try to modify it this weekend (if my kids allow me)…

Interactive:

NeurphologyJHT:

Eric


#10

You’re very kind Eric, thank you!
I’m thinking of uninstalling my imageJ, and then installing it again without any other plugin or macro but Neurphology…maybe some kind of…conflict? really don’t know…
Thank you again!
Arianna


#11

Reinstalling ImageJ is a good idea.
You may also want to try installing it on a different computer.


#12

Hi, unfortunately nothing I could try solved my problem. I unistalled my ImageJ, downloaded it again, both 1.43 version and 1.50 version (unexpectedly plugin runs only on 1.50 version), in different computers, installed only Neurphology as a plugin, but I face always the same problem, with the same strange output (144… everywhere).

If anyone has some other suggestion, I would be very grateful :slight_smile:


#13

So you are saying your results, when running NeurphologyJHT, do not match the ones posted by @hwangeric, right? Not even close?

The Troubleshooting topic The same plugin gives different results on different machines! might help. You can also run the System Information command (press L for the Command Finder to find it easily) to dump a very complete log of your system configuration including plugin versions etc. And if @hwangeric did the same, you could diff them to see where the differences are.


#14

Thank you @ctrueden, I will follow your advices…this mystery has to be solved! :confused: