New Extended Particle Analyzer version - note the changes

biovoxxel
analyze-particles
Tags: #<Tag:0x00007fd542f450a0> #<Tag:0x00007fd542f44f38>

#1

Dear all,

In feedback with @aryeh and Volko Straub, the new version of the Extended Particle Analyzer (BioVoxxel_Plugins version 2.0.1) fixes a bug (present in the BioVoxxel_Plugins version 1.1.8, older versions were not affected by this) regarding the use of the “pixel units” checkbox. Now it reacts again as the standard Analyze Particle… function. This means: activating the “pixel units” checkbox limits the analysis to the parameters in an uncalibrated fashion by using pixel (e.g. for area or length like the feret). Otherwise, calibrated units will be used.

In addition, I added a new checkbox on top which enables now to separately choose if the output table should show the values in pixels or units for calibrated images independend of the “pixel units” checkbox. Non-calibrated images do not show this options.

Advantage is, that you can limit object analysis by using pixels (if easier to set) but still get the output in units or the other way around.

So, everybody who recently used the Extended Particle Analyzer (of BioVoxxel_Plugins version 1.1.8), please cross-check on an example that the output is as you intended to not mix-up units and pixels in an analysis.

For everybody running the EPA in a macro, you might need to put the “pixel” keyword now before the area parameter limitation. The rest should not be affected.

If there should arise any problem by using the new version let me know.
Regards