Problem when exporting to excel (comma/dot?)


#1

when i export my results to a CSV file, all the floats are written like that (eg. 0.06497).
as a matter of fact, Excel didn’t recognize that these are floats and I’m obliged to change the dot by comma manually.
So, can you help me if there is a solution to export on the right format like that (eg. 0,06497).
Regards.
Fares


#2

Good day Fares,

I would try to change the setting of Excel.

Did you try to import the CSV-file to Excel via its menu command. Then you can specify the separators etc.

HTH

Herbie


#3

Hello Herbie,
Yes, it’s the same situation .
Fares


#4

What you write is a bit strange, because CSV means “Comma Separated Values” and if you need decimal commas instead of decimal points, this may lead to problems.

Did you open the file in a text editor and did you inspect in which format the values are actually written?

Did you change the CSV suffix to “.txt” and import the file via “Open” to Excel?

Regards

Herbie


#5

I know it’s annoying.
I think you have two possibilities:

  1. change the excel setting or system settings
    https://www.officetooltips.com/excel_2016/tips/change_the_decimal_point_to_a_comma_or_vice_versa.html

  2. import time by time your csv and specify with advanced option what is decimal for you the comma or the dot
    03
    10
    17

I use this kind of workaround usually.
And I export .csv or .txt from ImageJ/Fiji script