"Set Scale" problem since updating OS X High Sierra (10.13)

measure
analyze-particles
imagej
scaled
java
mac-os
high-sierra
Tags: #<Tag:0x00007fd6a17a3878> #<Tag:0x00007fd6a17a3698> #<Tag:0x00007fd6a17a3508> #<Tag:0x00007fd6a17a3288> #<Tag:0x00007fd6a17a3148> #<Tag:0x00007fd6a17a2e50> #<Tag:0x00007fd6a17a2cc0>

#1

Since updating my Mac OS X to High Sierra (version 10.13), I have been unable to Set Scale (Analyse > Set Scale), in order to perform measurements on my images.

More specifically, I am able to change any of the fields within the “Set Scale” dialog (Distance in pixels, Known distance, Pixel aspect ratio, etc.). I have tried “Click to Remove Scale”, in case there was one already assigned, but this does not work either. Scale remains as “< no scale >”.

I have also tried measuring on my image first (to determine the number of pixels I wish to set as my scale), but this does not get applied automatically in the “Set Scale” window as it previously did.

I am using the latest version of imageJ (1.50i), + Java 1.6.0_65, 64-bit. The Java installed on my machine is the latest Version 8, Update 144, build 1.8.0_144-b01.

Is anyone able to find out why I am unable to set scale and make measurements? Your help would be much appreciated!


Issues with OS X High Sierra OS update
Unable to type to set scale
#2

I have not yet upgraded to 10.13 personally, so cannot investigate thoroughly right now, but I am curious: does it work if you download the latest version of Fiji from https://fiji.sc#download? As of this writing, that package includes Java 1.8.0_66. And what if you launch ImageJ with a different version of Java? Specifically, the latest version of Java 8? Does that behave any differently?


#3

Hi ctrueden,

Thanks very much for your suggestions! I can confirm that:

– The problem is resolved using the latest version of Fiji (ImageJ 2.0.0-rc-61/1.51n; Java 1.8.0_66 [64-bit])
– The problem is also resolved launching ImageJ with my current installed version of Java (Version 8, Update 144, build 1.8.0_144-b01). I did this by opening “ij.jar”, after copying it from “Contents/Resources/Java” into my ImageJ directory.

Does this suggest it could be a compatibility problem with the innate imageJ Java version (1.6.0_65, 64-bit) and Mac OS X 10.13?


Unable to change numbers in Set Scale dialog
#4

Perhaps. More data from other users would be useful here.

I am not sure what you mean by “innate ImageJ Java version”, though: on macOS, Java 6 (e.g., version 1.6.0_65) is installed/available as part of the OS, not bundled with ImageJ. Newer macOS versions do not distribute Java 6 anymore, and in fact when you upgrade macOS, it often gets uninstalled. Since you have 1.6.0_65 specifically, I am guessing you installed it yourself from the Apple web site.

You can run this script from CLI to analyze which Javas are installed on your system in more detail.