SWC extension tracing issue

simpleneuritetracer
plugin
segmentation
Tags: #<Tag:0x00007fd547ffa360> #<Tag:0x00007fd547ff9ff0> #<Tag:0x00007fd547ff9af0>

#1

Hi!

I have encountered an issue with the Simple Neurite Tracer when I load a SWC file. When I reach a certain number of paths, a number of lines appear when I open the file after closing the program. These lines do not appear for all the paths, though, and they become green when I select the associated path. Example in the image:

Does anyone why it happens and how to solve it?

Thanks in advance!


#2

Perhaps @tferr can assist you in this?


#3

I have never seen this before. It looks as if the swc file is ill-formed: The flag indicating the parent branch for the erratic paths was missing, and the program assigns them to the origin (x=0,y=0) of the tracing canvas, i.e., the upper left corner of the image.
It would be really useful to know how you obtained this swc file: From SNT directly, another program? Can you place the original image, the SNT .traces file you may have and the problematic SWC file somewhere we can access them?


#4

@rjfranj,
Just a quick followup. Did you manage to solve the issue?


#5

Hi, tferr!

Yes, it has been solved.

I obtained the file using SNT. I showed the issue to my supervisor and he has solved it somehow, fortunately. As you have said, it sets the coordinates to origin, for some reason.

I will ask him if he minds if I share the original image.

Thanks a lot!