Trackmate does not display spots when loading file

trackmate
Tags: #<Tag:0x00007fd5464b0500>

#1

Dear all,

Since a couple of days I’m having trouble with loading my TrackMate files. The detected spots seem to disappear after 5-6 frames, so I can not edit the tracks anymore.
I’ve already tried a lot, including adjusting the TrackMate version in the XML files, since I’ve noticed that I am now using a newer version. The TrackMate version is 3.5.1-SNAPSHOT. Even when I start a new TrackMate file, save it and reload it, the spots disappear.

I cannot find the problem and it is really frustrating because I have many files with many cells that I’ve tracked.
Does anyone else have this problem? I hope someone can help me!


#2

Hi @anne1.

This seems to be a bug. Can you send me one of the faulty XML file?


#3

Thank you for your quick response
Can I email it to you? Or send it to you in another way? I cannot attach a file to my messages, yet.


#4

I’ve installed older versions of imagej and trackmate and the same problem happens. Do you have an idea what goes wrong?
Kind regards


#5

Not yet.
Can you send me the faulty file?


#6

here you can find the link to a faulty file.
thank you very much for your time


#7

Hello,

Did you already have some time to look at my problem, about the disappearing spots? Thanks in advance


#8

Hi @anne1
Sorry i did not catch the notification for the file upload.
I will look into this this week.


#9

Thank you very much. If there is anything that I can do to help you find the problem, please let me know.


#10

I have identified the problem. It seemed that for some of the files the z- and t-dimensions were not set correctly. After changing the settings, the problem was solved.
thank you though for your time


#11

Glad it works!
best
jy